Pyzed valuerror

Traceback (most recent call last):
File “c:\Program Files (x86)\ZED SDK\zed-python-api-master\src\”, line 194, in
extList = cythonize(extension, compiler_directives=cython_directives)
File “C:\Users\user\AppData\Roaming\Python\Python39\site-packages\Cython\Build\”, line 973, in cythonize
module_list, module_metadata = create_extension_list(
File “C:\Users\user\AppData\Roaming\Python\Python39\site-packages\Cython\Build\”, line 816, in create_extension_list
for file in nonempty(sorted(extended_iglob(filepattern)), “‘%s’ doesn’t match any files” % filepattern):
File “C:\Users\user\AppData\Roaming\Python\Python39\site-packages\Cython\Build\”, line 114, in nonempty
raise ValueError(error_msg)
ValueError: ‘pyzed/sl.pyx’ doesn’t match any files

I’ve got this error in windows 11,cuda 11.4 and zed sdk 4.0 I run the setup file in zed python api master, Do you have any idea about it? Explain it in detail since i am not an expert for it.


The easiest way of installing the python API is to run the script that is in your installer folder. Can you do that instead ?

I already did it without any problem,but doesn’t work, and it worked when I changed into import pyzed as sl. Maybe the valuerror is related this problem?

We released a fix lately last week that solve the not working. Can you try again to run and give me the error messages you get (if you get one) ?

Hi @niuge12138, please open a new topic, since your question seems unrelated.