Python svo2 play

I can’t play my svo2 file with Python. But same code working for svo file.

Hi @OnurS,

Can you please share the result of the ZED_Diagnostic tool json file? This will help troubleshoot your issue.
We have already identified this issue and are working on a fix. In the meantime, I would suggest using the environment variable:

export ZED_SDK_SVO_VERSION=1

before running your script to save your SVOs as gen1 and you should not have any issues.

I Just need image, time stamp,frame number and imu. Is there a way to get this? My old code is getting this in svo but not in svo2. Am I have to wait your update, can’t we figure out a way now?

Would it be possible for you to send an SVO file that has this issue? We will be able to identify the issue faster and provide a fix in a timely manner.

I am sharing 2 svo2 file, one of them is short and zed.grab() function is not working on it.
the other one about 13 min and it has error message like this:
receive MCAP_Status error: cannot read MCAP in time order with no message indexes

link to my videos and codes :https://drive.google.com/drive/folders/1cbeRjqI9yLt6g4rBpiglOfD0-s-0vJv8?usp=sharing

Hi,

Thank you for responding quickly, we’ve been able to download the files to investigate further.

Can you also run the ZED_Diagnostic tool and share the resulting JSON file?

Thanks
you can use same link for it.

Downloaded, we have all the info to troubleshoot, we will get back to you once we find the source of the issue.

Any progress? Or can you give us date? We have recordings for experiments and we are waiting to use them.

Hi @OnurS,

Sorry for the delay.

We have a bit of trouble reproducing your issue on your platform, I am going to need a little bit more information regarding your problem.

First of all, can you update your SDK version to the latest 4.1.1, which includes a few fixes regarding SVO v2? ZED SDK 4.1 - Download | Stereolabs

Can you open the SVO file using ZED_Depth_Viewer? Do you have the same behavior when running this official sample: zed-sdk/recording/playback/mono/python at master · stereolabs/zed-sdk · GitHub?



image
I updated to the newest SDK 4.1.1 and tried to play videos with the Zed_Explorer and Zed_Depth_Viewer. Shorter videos can be played by the Explorer and opened with the Depth Viewer too, but longer ones give an error in both of them. I also tried the official sample that you provided, but again, both shorter and longer videos can’t be opened and give errors separately. The shorter one says “SVO end has been reached” and the longer video error says “MCAP_Status error”.
By the way, you mentioned that you are not able to reproduce the issue. Does that mean you were able to play botu videos?

Hi @OnurS,

Thank you for the additional information.

I have indeed been able to open the SVO on a Ubuntu22 machine, we are looking into the issue of SVO2 recorded on Jetson and opened on Windows.

So, is it possible to play all of the videos (both long and short) and obtain the desired data (timestamp, frame number, IMU) on Ubuntu, even if the videos were recorded on a Windows machine?

Hi @OnurS,

Recording and viewing SVO data should work regardless of the platform. We are investigating these bugs between Jetson and Windows more thoroughly and will get back to you once we can provide a fix.

I mean if we switch to ubuntu will we be able to use videos without any trouble in python?