Python body tracking/object detection samples shows window with no detections


[Windows 11, CUDA 12.1, Python 3.11).

I have set up the Zed 2i according to the documentation with CUDA 12.1. After resolving the error with the (OpenGL-accelerate whl did not work, so installed OpenGL manually). I was able to get the body tracking to work however it does not make any detections. I saw in another forum post to run the diagnostics and optimize the AI models which are done. The object detection sample shows Corrupt SDK error despite multiple reinstalls of the SDK.

Thank you for your time.

Hi @faiz, welcome to the forums!

  • Could you run ZED Diagnostic and share the resulting json file with us?
  • Is it just Python samples that do not work? You can find compiled and ready to run .exe files in C:\Program Files (x86)\ZED SDK\samples\bin. Can you run ZED_Body_Tracking_Viewer.exe and tell me if it works?
  • Can you try re-running the script after you’ve installer OpenGL manually?

Hello @JPlou,
Thank you for your response. As new users cannot attach files, I have uploaded the json to this google drive link along with a screenshot of re-running the script, It uninstalls the version of OpenGL that is installed and tries to reinstall it. I have tried the ZED_Body_Tracking_Viewer.exe and that works as expected.


Hello @faiz, sorry for the delay.

It seems it all tracks back to a pyopengl-accelerate installation error in our script. :thinking:

Can you try the workaround of this post? (installing pyopengl-accelerate and removing the line trying to install it from our script (look for the package’s name in the script).

Hello @JPlou,

I tried the method from the post commenting out the part where it installs pyopengl-accelerate, and installing it manually without any luck.

Thank you for your time

Hello @faiz,

Can you please post the errors/logs you get?

Hello @faiz,

Can you please post the errors/logs you get?

[Discourse post]

R&D Engineer
Stereolabs Support