Problem with loading DLL - tips in other threads not working

I am struggling to get the sdk to work.

I get this error-message:
File “c:\Users\70550305\OneDrive\3d\python\zed\”, line 21, in
import as sl
ImportError: DLL load failed while importing sl: The specified module could not be found.

I have done the following:

  1. installing SDK
  2. Creating an environment in Anaconda
  3. opening a terminal from the environment - running the script
  4. Checking that the pyzed package is installed.
  5. Launching a script from the same enivronment

I have tried both the sdk 3 and 4, and also with different python version, but now i do not have any more ideas. I see that more people have this problem, but their solution of copying files has not worked for me. I have also tried to downgrade python to 3.6

Any help is appreciated :slight_smile:

Yes, more and more people have this issue.

You can download a dependency walker tool (like this one) and use it on the pyzediot module. You’ll see exactly what dll is missing.
Usually, what’s missing is from nvidia, especially nvencodeapi64.dll.

Thanks for the answer!

I found that the following dll:s were missing:

This solved the problem, thank you!