Passing ZED into Docker without Privilege mode

Hello!

So I’ve been reading online and it seems like the only way to pass my ZED camera into a docker container is by giving the container privilege. It’s not the best solution, as most people state, but it’s the solution that works.

I was wondering if there was any viable way of passing through my ZED camera into my container without having to give it privilege?

When I ‘diff’ the /dev directory, I see that the ZED camera produces three new devices: media1, video2, and video3, but I’m not intuitively sure if I can just pass one of these devices to the docker.

I’ve also tried passing the entire /dev volume into the container and I still couldn’t get the container to detect the ZED camera.

I looked into using udev, trying out this script: Setup the udev rules for the ZED cameras · GitHub , but no luck:(

Hi,

You are correct, using privilege is the simplest solution and you tried the correct things. It should work without privilege when the udev rules are set up on the host.

I think mounting the dev volume is only necessary to get access to the camera when plugged in after the container started.

What exact commands did you use?