No LiveLink sources found in build when using Unreal and Multicam fusion


So I am using the test project for zed live link fusion and when I run the project in editor, the sources menu appears by pressing ‘S’. I can then choose the machine I want to receive live link data from.

However, when I build the project I do not see the sources menu. In fact, there are 0 sources available. I read that unreal will send out a poll message prior to establishing live link connections. So, what I’ve tried is:

  1. Enable in and outbound rules for my UDP port (which I may have done incorrectly)
  2. Print out the sources (which results in none found)
  3. Save a Live Link preset and load it in at runtime via the ‘Apply to Client’ node (which works in edit mode, but not standalone build).

I also had trouble building my project using Live Link, so I found a post about overriding the build environment since Live Link and unreal core use the same files (?). I used this line:
bOverrideBuildEnvironment = true;
inside of to solve the build issue. I have a sneaking suspicion that this might have to do with the problem of live link not working on build.

Any tips or direction?


Can you try adding the -messaging argument when running your executable from a terminal?

Let me know if it helps.

R&D Engineer
Stereolabs Support


I tried this as well. It did not work.

I also tried building for production release and whenever I press ‘S’ the game crashes.

Any other tips?


Are you testing with the sender on the same machine as the receiving project?
I think this should rule out firewall issues if it still doesn’t work, or point toward them if it does work.

Same machine.

Here are my settings (ZED360 Calibration and LiveLinkConfig:

Calib1.json (1.1 KB)
ZEDFusionLiveLinkConfig.json (769 Bytes)

I don’t see anything wrong in there, and if it works in editor, those files are correct.

Can you comment out


in, and also remove the

bOverrideBuildEnvironment = true;

you had to add?

You will have to use the -messaging command line argument when launching the .exe application.
Can I also ask what version of UE5 you’re using, and if it’s the launcher version or a compiled version?


I’m using 5.3.2.

I tried these things. I also had to comment out:

BuildEnvironment = TargetBuildEnvironment.Unique;

because the build would not complete without removing it.

Still no luck :frowning:

I have a feeling this is a live link issue and not a zed issue.

Hi @ZanderCodes,

If you haven’t already, you can try deleting the rules about the live link applications in the firewall, restart the computer and it should ask you to enable the application again when you start it. That may be worth a shot.

Sorry, I don’t have many ideas on this, and since I could not reproduce it on my side, it’s difficult to investigate. And as you said, it may be not related to our implementation.

Great, this worked!

I thought I had the firewall rules set properly, but I guess the settings I created were actually restricting.


1 Like

The only problem is that if I allow any firewall permissions at all, then the live link connection will stop working. So, as long as I do not accept that message which comes up the first time you run and I remove any firewall rules for live link (and restart computer) it works. :man_shrugging: