Neural model optimization issue on Jetson ORIN

Hi,

I am trying to see the result of neural option in the ZED_Depth_Viewer application using Jetson Orin but during the optimization process this error appears:

image

Couldn’t find any solution or information how to change to the “correct” version of nvrtc to make able to run optimization for neural model.

My platform:

  1. Jetson Orin dev kit with Jetpack 5.0 Ubuntu 20
  2. ZED SDK for L4T 34.1 Beta (Jetpack 5.0 DP)
  3. Zed 2i stereo camera connection with original type C cable

Any thoughts, solutions?
Thanks

Here is an output from terminal

Hi @nyrjan
can you try if updating the Jetson solves the issues?

sudo apt update
sudo apt upgrade
sudo apt install nvidia-jetpack

Hi Myzhar,

I did it for the first time when I launch the Jetson Orin,
I repeat it, nothing has changed.

I have tried the same thing on desktop workstation and it worked, probably it because it different gpu/cpu architecture comparing with jetson orin.
Workstation: Ubuntu 20, Nvidia A4000 Quadro RTX 16gb.

By the way is there any way I can make this optimization, save it somehow to some file, and export directly to the Jetson Orin from my workstation?

No, the optimization is performed according to the GPU used.
So you must perform the optimization on the Orin for its GPU model.

We just released the ZED SDK v3.7.7 for JP5.0.2.
Can you download and test it with an upgraded Orin?

Yeah I updated the jetpack to 5.0.2 and installed SDK 3.7.7
I made an optimization and it goes through the process with the same issue (now it was only warning without crashing).
But at the end it’s just showed me that it’s been done. When I am tried to run again the ZED_Depth_Viewer with the Neural mode it keep telling me that it’s not optimized. I click again make optimization but now it’s just showing the video from camera but no any point cloud and depth data.
This is output from terminal
Screenshot from 2022-09-13 19-19-59

This screen from ZED Depth Viewer

Please try to optimize the NEURAL depth model outside ZED Depth Viewer:
$ ZED_Diagnostic -nrlo

Hi Myzhar,

I cleared previous model with ZED_Diagnostic -aic and make ZED_Diagnostic -nrlo.

How I should save this model or what is next step? I am not sure whether or not it saved it somehow, because running the Diagnostic tool image
it showing that it wasn’t optimized.

Hi @Myzhar

Any updates on this how to solve this issue?
So far I reinstalled/reflashed the OS in Jetson Orin using the SDK manager to the latest (I believe August release of JP 5.0.2). Installed the latest sdk 3.7.7 and make an optimizatio using this command ZED_Diagnostic -nrlo in the terminal outside DepthViewer.
After it completes, DepthViewer can’t switch to Neural mode and asking make an optimization again. After clicking OK to the prompt message box it goes for probably 1-1.5min in the “freeze mode” and then showing only the RGB view but with a blank screen in the depth and point clowd window section.

the same as here

What should I do to fix this problem?

Please try the following command sequence and post the relative output:
$ ZED_Diagnostic -aic
$ ZED_Diagnostic -nrlo

We need more information to understand what’s happening on your machine because the behavior is really weird.

Hi @Myzhar
Here are the output

Could you please tell me explicitly what kind/type of information you need? I can provide as long as I know how to get it from the jetson itself.

Please run again the command $ ZED_Diagnostic -aic, then run the python script in the attached zip file and post here the full output (no screenshots).

test_neural_depth.zip (45.4 KB)

Initially there was a problem with No Module found:OpenGL, I fixed with the following command
pip install pyopengl
Here is an output, I believe this is right script

output.zip (1.6 MB)

Looks fine to me, but still I can’t see the same result in the ZED_Depth_Viewer app, and worth to mention yet, I made an optimization using your script, but in the ZED_Depth_Viewer I need to make run it again.
One more thing should I upgrade the firmware of zed2i camera, I am not sure is it relevant or not?

The FW version is not relevant and you should have the latest available.

Right, but what about my issue any thoughts ideas, I mean did you check the output t attached?

The output is correct, The point cloud has details that only the NEURAL depth mode can generate provide. We are investigate the problem of ZED Depth Viewer to understand why it’s not correctly working in the Docker container