Migration from 3.8.2 to 4.0.3 on Jetson Nano


I installed the newest version of the ZED SDK. When I try to enable object detection, I have the following issue :

However, the file is created in the resource folder. Can someone help me ?
I tried removing the /usr/local/zed directory and reinstall it but it still doesn’t work.



Hi @avanmalleghem
the memory of the Jetson Nano is not enough to complete the optimization of this AI model.
Have you tried to enable the swap file?

I tried but still have the same issue even with the “performance” model :

Can you try to optimize the AI models manually by using the ZED_Diagnostic tool?

Still have an issue with this model. Here is the full output :

If I relaunch the command :
Screenshot from 2023-05-31 13-34-59

So yes, optimization is not working…

I tested it on a new JetPack 4.6 install (R32.7.1 kernel 4.9.253) and I have the exact same issue so that’s really something related to your library.
Can you fix it on your side and temporarily sends me the BODY_FAST_DETECTION optimized for jetson nano file ?

Can you confirm that you cannot optimize only the MULTI CLASS, the MULTI CLASS MEDIUM, and the MULTI CLASS ACCURATE models?
Are all the other models correctly optimized?

here is what I have in the “resource” folder :

I guess it answers to your question. Please, can you provide me the objects_performance model optimized so that I can continue my development meanwhile you fix the issue ?

We’ve identified the issue, it impacts the object models on all jetsons using JetPack 4.6. A fix should be deployed in the next version, we’re sorry for the inconvenience. In the meantime and if possible you could use the 4.0.2 which is not impacted. You can download it using this direct link; https://stereolabs.sfo2.cdn.digitaloceanspaces.com/zedsdk/4.0/ZED_SDK_Tegra_L4T32.7_v4.0.2.zstd.run

1 Like