Latest SDK breaks Jetpack after apt-get upgrade

I have a small production line where I use ZED2’s with a Jetson NX with the following details:

  • Jetpack 4.5.1
  • ZED SDK 3.5.4
  • After flashing each SD card with the clean Jetpack image, I run first apt-get update & apt-get update
  • I then install the ZED SDK with python API and all default options turned on

This has been working fine for the 5x devices that I assembled over the last two weeks.

This process has suddenly started giving issues in the last two days. After rebooting at the end of the above steps, my Jetson is unavailable over wifi, and the HDMI output is stuck during boot on the screen shown here.

If I reboot after the apt-get upgrade then everything is still fine.
It is only after the SDK install that the issue starts.

I’m running all of the exact same commands which worked in previous weeks, so there must have been an updated package which is now clashing with the SDK. I have also tried v3.5.6 of the SDK and the exact same issue still pops up.

I can still log into my jetson via the usb-micro serial terminal, and it seems to be running mostly ok. But I no longer have any GUI, and it no longer appears on my wifi after rebooting.

How on earth do I begin to debug this?

It seems to be a known issue of JetPack 4.5.1 RAMDISK: incomplete Write (28583!=29663) - #3 by JerryChang - Jetson AGX Xavier - NVIDIA Developer Forums

That would be surprising if caused by the SDK as the most recent dependency change was over a 1 year ago (ZED SDK 3.1) and the installer script did not change between minor revisions of 3.5.

@adujardin thanks for the quick reply.

I agree that it doesn’t seems to be related to that RAMDISK line in the logs. That appears during boot all the time even before your SDK is installed.

If you’re confident that your SDK dependencies haven’t changed, then it looks like there’s something new being installed or upgraded with apt-get upgrade that is clashing with your SDK somehow.

Any idea how this could happen and how I can go about debugging it?

From what I understand from the Nvidia forum post: the user did not use the ZED SDK, the apt-update/upgrade was the only cause of this issue.

Your solution seems, for now, to flash the 4.5/4.5.1 and not upgrade it (ever).

Later you could use JP4.6 when the next version of the ZED SDK is released (planned for the end of the month)

Thanks @adujardin, this issue is still occurring if I use my existing build process which includes a

sudo apt-get upgrade

but I’ve found a workaround for now by not performing that upgrade command, and then manually tracking down any required updates that I’m missing. Not really a solution, but we can close this for now and I’ll just wait for your JP4.6 build.