Jetson nano jetpack 4.6

sova@sova-desktop:/usr/local/zed/tools$ xrandr

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 520mm x 290mm
1920x1080 60.00*+ 59.95
1680x1050 59.96
1440x900 59.89
1280x1024 75.03 60.00
1280x960 60.00
1280x720 60.00 59.94
1024x768 75.03 70.07 60.01
832x624 75.05
800x600 75.00 72.19 60.32 56.25
720x480 59.94
720x400 70.04
640x480 75.00 72.81 67.06 59.94

sova@sova-desktop:/usr/local/zed/tools$ ./ZED_Diagnostic

nvbuf_utils: Could not get EGL display connection
nvbufsurftransform:cuInit failed : 999

what sould i do to run this program ?


Can you tell us a bit more about your setup here ?

i solved that problem , its about gpu and torch so i change to another jetson
now i have another problem with driver usb 3.0
i dont know what should i do
i used all are ports but its not working and show the same mistake

Can you tell us a bit more about your setup here ? I don’t know what hardware you are running your camera on. Seems like a jetson, but what carrier board? Can you send the output of the ZED Diagnostics too?

jetson nano 2gb developer kit
jetpack 4.6
ZED_Diagnostic_Results.json (9.3 KB)

Your 3.0 USB controller does not seem here. Try to switch USB port maybe ?

Are you kidding me? I told you I’ve tried all the ports

is there any benefit from your community?

Hi, sorry. We have a lot of request to keep in mind, I did not see that you checked all the ports.
Do you have something else plugged in that could suck up the bandwidth ? is your cable OK ? Did you tighten the screws ? Do you use a USB hub ? how do you power your jetson ?

Can you send here the output of lsusb ?

I directly connected the camera to the Jetson Nano port using a standard USB cable, without any additional tools or devices. The camera works properly when connected to a computer. The Jetson Nano is powered by a source providing 5 volts, 3 amps, with a maximum power output of 15 watts.

jetson@jetson-desktop:/usr/local/zed/tools$ lsusb
Bus 002 Device 003: ID 2b03:f880
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 4e53:5407
Bus 001 Device 004: ID 413c:2113 Dell Computer Corp.
Bus 001 Device 007: ID 2b03:f881
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The ZED should appear here. If the camera works on another machine, I guess the issues comes from the Nano. You can try to flash it again, if you haven’t tried already.

we rolled up the sdk on a clean image
, which version do you recommend to flash

For the first version of Jetson Nano you d’ont have much choice. You need L4T 32.7, which would be Jetpack >= 4.6.1 I guess
About the SDK, just pick the latest one.


Good morning < we have some problem with gmsl drive
Plese check this log file
there is recommendation about gmsl
please help me we need to fix it prioritetly
log_install.txt (44.9 KB)


I don’t yhink you have an issue with GMSL. Your system does not handle sudo command, which is the issue. Can you give me the output of sudo ls to confirm?

If that is the case, your user was created wrongly during the flash / The flash was bad itself. That can occur if you tried to tweak, copypaste, or change the permissions in the files that are in the folder /home/nvidia/Linux For Tegra/.

Allright then. I don’t see an issue in your latest screenshot. What if you install the ZED SDK, latest version now ? Can you send me the logs ?
You will not be able to have GMSL on this board, we don’t have a driver for it. But I think you have an USB camera, not a GMSL one.


for 4.6 jetpack ?

which logs do you want ? wehre can i find it ?

Yes, 4.6. The logs of your terminal when you run the installer.