Jetson nano and docker


I’m trying to build a camera streaming setup . I’m working on a Jetson nano with docker.
From the hub Docker Hub, I tried to use differents images :

The build of image is fine, when I tried to run a python example “” is launched.
I get stuck on “======NVMEDIA :NVENC =======”

On youtube video, I saw that normally I should get message like "[Sampe] Streaming on port XXXX
[ZED][STREAMING] Streaming is now running …
[ZED][Streaming] adding receiver with IP: XXX.XXX.XXX.XXX
(where X is defined as I want)

Did someone to try setup a streaming setup ? I’m going to user docker-compose to easily configure my zed cameras, I will share my code when everything will be fixed.

Thanks in advance

Hello and thank you for reaching out to us,

You should probably try the sample on your PC first, and check the output.
What is your version of jetson OS ? jp4.6.1 would be L4T-r32.6, jp4.6.2 would be L4T-r32.7.
You can run sudo apt-cache show nvidia-jetpack to know this.


Hello thank you for your fast reply,

In the progress, I managed on the host computer to stream with his own ip and everything works (with and without docker).

Concerning the jetson, you were right the version I have is LA4.6.
I managed to make the stream work only once with the jetson and the host pc (using ZED Explorer and entering the IP of the zed which is and the port 30000) .

When launching ZED Explorer via a terminal and entering the IP address, the error is :

"zed@zed-CUSTOM:/usr/local/zed/tools$ ./ZED_Explorer
** SVO] Hardware compression (NVENC) available
[Streaming] Warning: Failed to retrieve camera settings from sender
[Streaming] Error: Stream opening timeout 350
[Streaming] Warning: Failed to retrieve camera settings from sender
I thought then to put the .conf file of the zed on the two computers, it did not solve anything. My network is full local, I just put internet to pull my code and conf of cameras.
Do streaming receiver needs internet maybe ?