Issue with ZED SDK installation


I have an issue after installing the ZED SDK on my desktop PC.
I download and set up ZED SDK 3.8.0 but after installation and when I run the ZED Diagnostic app, I get an error saying Your ZED SDK needs to be updated as shown in image 1.

additionally, when I run the ZEDfu app, I get an error saying the entry point is not found. as shown in this img 2 img 2

However, when I install ZED SDK it works completely fine on my laptop. do you have an idea what is the problem here?

Hello and thank you fro reaching out to us,

It seems that you have a mismatched version issue. The error when running is the same than the one with ZED Diagnostics : It tries to run one version of ZEDfu, but while loading another version of the SDK.

You probably have some kind of old installation somewhere that needs to be removed. Clean completely any version of the SDK you could have copied somewhere, then install the SDK again.


thanks @alassagne .
when I deleted the old SDK it still did not solve it.
but when I deleted any file related to ZED and ZED SDK it solved the issue.


Being curious and it might help others, do you remember which files you deleted ?

I don’t remember all to be honest but from what I remember.

trial zed 2i
zed (folder)
ZED SDK.old (folder)
ZED (folder)