Incompatibility of ZED SDK with NVIDIA VPI on Jetson boards

I have been playing around with NVIDIA’s new VPI api for programming fixed function hardware called PVA and VIC on Jetson boards. I tried the stereo disparity estimation example with zed camera using zed sdk to pull frames and encountered errors. I posted about it on jetson forums and after some tests, it turned out that the problem might be caused by ZED sdk accessing image buffers concurrently with VPI when VPI’s CUDA algorithm is used for disparity estimation. I looked around and found the purely opencv based library for pulling frames from zed camera. I haven’t tried it yet, but it seems like that should resolve the issue. In the meantime, I am posting this here if someone else encounters the issue or if the developers of zed sdk find the feedback useful.

Hi @dataplayer12
have you tried to use the ZED Open Capture driver instead of ZED - OpenCV Native Capture.
With ZED Open Capture you have more control over the camera still not using the ZED SDK.

Thanks for the tip. I tried with OpenCV Native capture and vpi cuda backend works perfectly well. At the moment, it is enough for my needs.

OK, don’t hesitate to ask for more information if you intend to use ZED Open Capture.

Good information thanks for sharing