Import pyzed error on Jetson Nano

Hello,

I installed JetPack 4.6 on Jetson Nano. The python version is 3.6.9. The ZED SDK is installed and giving the camera image without any problem on ZED Explorer. When I try to install pyzed through the get_python_api.py, it gives “pip failed to setup pyzed package (pyzed was NOT correctly setup)” error after numpy installation error.

Then I run pyzed-3.7-cp36-cp36m-linux_aarch64.whl file and imported pyzed without error. However, to access the camera I have to “import pyzed.sl”. When I import pyzed.sl it gives me “Segmentation fault”.

I followed the instructions and came this far, I could not overcome this problem. Could you please tell me any solution?

Hello and thank you for reaching out to us,

Can you send me the output of the script get_python_api.py ? I assume you ran it with python3 (python is python2 by default and is not supported)
Also, what do you mean by running the .whl file ? You cannot run it, only install it.

Best regards
Antoine

Hello, thanks for your reply.

I solved the problem as follows:

My code was starting with import pyzed.sl as sl

I changed it as:
import cv2
import pyzed.sl as sl

It gave libjpeg.so.0 package not found error. I installed libjpeg.so.0 package then everything went fine. Now, I can get the image via python.