How to stop ZED mini from publishing both tf and tf_static topics?

Hi everyone,

I have a ZED mini and I am using it through the zed_ros_wrappers. I am trying to find a way to disable the /tf topic that is being created when I subscribe to the /odom topic.

Although by using the launch file named zed_no_tf.launch the /tf topic returns empty and echoes nothing, the /tf_static still returns the static transformations of the camera frames.

Is there a way to stop publishing the /tf and /tf_static completely?

Thank you in advance.

Hi @Antonis
you must set the publish_urdf launch parameter to false:

Hi @Myzhar,

thank you for taking the time again to respond to my issue. I notice that there is a drop in the frequency of the odometry topic when I set the URDF setting to false. Is there a way to overcome this ?

That’s expected if there are no publishers for the required mapodombase_linkcamera_base_link TF chain.
The node when starts the positional tracking module it checks for TF and waits for them.
You can try to disable the Positional Tracking module: