H264/H265 SVO recording freezes instantaneously

I have a minimal c++ application that is set up to record to an SVO file. It’s currently set up on a Jetson TX2, and is running within the StereoLabs docker image zed:3.7-devel-jetson-jp4.5.

If I set the compression_mode to anything besides LOSSLESS in the recording parameters, my camera.grab() loop freezes up permanently as soon as recording starts. The svo files get created, but are only about 280bytes in size.

Again, if the compression is set to LOSSLESS everything works fine, so I know it’s not a problem with the code. I’m wondering if I’m missing some codecs since the H264/H265 compression modes freeze the application up? Or maybe its because the H264/H265 compression modes use the GPU (and the problem lies there) while LOSSLESS uses the CPU?


That would depend on your GPU. Even if it’s CUDA-compatible, sometimes it does not have the hardware encoder/decoder that’s required to write h264/h265. In this situation, you’ll only have lossless option. What’s your GPU?


I’m using a Jetson TX2, which has the Pascal GPU w/ 256 cuda cores. I know that H264/H265 encoding works on this setup… a year ago I ran this exact setup and the encoding worked perfectly. The only difference back then was that I was using the ZED SDK 3.5 docker image, where now I’m using the ZED SDK 3.7 docker image.

So this leads me to believe it must be some kind of configuration issue, potentially with the SDK 3.7 docker image missing required dependencies for H264/H265 GPU encoding.

Indeed. It seemed their was a bug with 3.7 earliest versions, which one are you using now ? in 3.7.4, it should be fixed.

1 Like

Ah that makes sense. I’m currently using 3.7.1, which is what comes in the latest zed:3.7-devel-jetson-jp4.5 docker image posted by StereoLabs. How often do those images get updated? Here’s the link to the image on docker hub: Docker Hub

In the meantime, is there a way to update the version via command line? I’m constrained to using docker for this setup, so I’m hoping I can start with that zed:3.7-devel-jetson-jp4.5 image and just run an upgrade via CLI in the Dockerfile.

These images are updated for most of our versions, I’ll ask why it was not this time.
In the meantime, you can totally build your own docker image, which takes ours as a base, and install a more recent version inside.