Errors ocurred during the optimization process

Hello Stereolabs team.

I’m trying to set up the my ZED2i in a laptop as I need to do some tests around the house, and I’m finding an issue when trying to optimize the AI Models.

When I try to run it, it freezes showing an empty diagnostic window, or it shows a message like the one shared in the screenshot that says Errors occured during the optimization process. skeleton_body38_3.5>= 2

ZED_Diagnostic_Results.json (15.9 KB)

Any ideas of what can be going on?

Thank you.

Hi @R2R0,

It appears support for GTX 950M GPU has been dropped in CUDA 12. Can you try installing the ZED SDK with CUDA 11 from our website: ZED SDK 4.0 - Download | Stereolabs?

Hey @mattrouss!

That fixed the issue and now all the AI Models are optimised, thank you! :grin:

However, when trying to get it running in Unity with the project I was working on in my other computer, I got stuck in this state in every scene.


And debugging the code I could see an error message that says my GPU is not supported .


Also, the blue led in the camera blinks. It blinks once, and right after that it blinks a bit longer (Like “._” in morse code). Then the pattern repeats itself.

In the Zed Explorer the camera works fine.

In the Depth Viewer, I got this message at the top of the window

And trying to run the sensor viewer, it freezes and I see this in the console that pops up

I’m using Unity 2022.3.18f1 and the package Zed_Unity_Plugin_v4.0.7.unitypackage

I’m attaching again the diagnostic with the models trained and the new version of CUDA (I uninstalled the old one before installing the one you told me)

ZED_Diagnostic_Results Unity.json (16.8 KB)


Hi @R2R0,

I apologize the message returned by Depth Viewer is correct, for Maxwell architecture GPUs (such as yours), the required CUDA version is 10.2 which is only available for ZED SDK version up to 3.8.

You can find the download for the installer here: ZED SDK 3.8 - Download | Stereolabs

Hey @mattrouss !

I did what you suggested, and I can load the Depth Viewer correctly.
Unfortunately, when I open the ZED Explorer now, it closes automatically before displaying the camera with no error message.

I ran the ZED Diagnostic and everything went good, and after that I ran the optimisations using the “ZED Diagnostic.exe” with the parameters -aio

But I think I will stop at this point, as I lost some functionality I needed after downgrading the Unity plugin to the version Zed_Unity_Plugin_v3.8.0.unitypackage

In case someone needs to do this too, if Unity closes automatically after doing the downgrade, with Unity closed, remove the ZED folder, then open Unity again (in safe mode if you can), and import the old unitypackage.

Let me know @mattrouss if you need more logs if you want to investigate the ZED Explorer issue, but for my part, we can close the ticket now as I need the latest SDK version.
I’m attaching the diagnostic in case its helpful.

Thanks a lot for your support :slightly_smiling_face:

ZED_Diagnostic_Results final.json (18.0 KB)

The latest message I sent was erroneous, we actually have an installer for Windows 10 and CUDA 10.2 for the ZED SDK 4.0.8. Can you please try it and see if ZED_Explorer works correctly?

You will also have access to the 4.0 features, however without some improvements provided by the newer versions of CUDA.

Hey @mattrouss, thanks for your message.

I already mounted the new setup, so I won’t need the camera working in the laptop soon. But if for any reason I need to use it again, I will follow your last instructions and I’ll post the results here :slightly_smiling_face:

Thank you!!