Error while running Zed utils: Segmentation fault (Address not mapped to object [0x38])

Hello everyone, i installed on my pc with ubuntu 22.04 LTS and cuda 11.7 for ZED2. I runned ZED_Diagnostic and optained this output:
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
Stack trace (most recent call last) in thread 17007:
#11 Object “[0xffffffffffffffff]”, at 0xffffffffffffffff, in
#10 Object “/lib/x86_64-linux-gnu/”, at 0x7f684aa199ff, in
#9 Object “/lib/x86_64-linux-gnu/”, at 0x7f684a987b42, in
#8 Object “/lib/x86_64-linux-gnu/”, at 0x7f684acfe2c2, in
#7 Object “ZED_Diagnostic”, at 0x456ba6, in
#6 Object “ZED_Diagnostic”, at 0x46df64, in
#5 Object “ZED_Diagnostic”, at 0x458bf4, in
#4 Object “ZED_Diagnostic”, at 0x4962e2, in
#3 Object “ZED_Diagnostic”, at 0x53fe49, in
#2 Object “ZED_Diagnostic”, at 0x53a244, in
#1 Object “/lib/x86_64-linux-gnu/”, at 0x7f684ba97878, in libusb_get_device_list
#0 Object “/lib/x86_64-linux-gnu/”, at 0x7f684a98af74, in pthread_mutex_lock
Segmentation fault (Address not mapped to object [0x38])
Segmentation fault (core dumped)

This appear also running other ZED utils.
Can you help me in some way? thanks in advantage.

Hi @franzhd
Welcome to the Stereolabs community.

What is the NVIDIA GPU card installed in your host device?

Hello! Tanks for the support!
my pc has a rtx 3070

Does it work if you run ZED_Diagnostic in console mode:
ZED_Diagnostic -c

Hello, running this ZED_Diagnostic -c, iT gave me this output
and an empty ZED_Diagnostic_Results.json.

What’s the output of the $ nvidia-smi command?
I suspect you are not using the latest NVIDIA driver for your GPU card.

Can you post also the output of the command $ prime-select query?

Hello Myzhar,
I’m having the same issue.
The is of course plugged in and the blue LED on the front turns on (and stays on until unplugged)
I can see the video when I open a camera app.
Running on Ubuntu 22.04, x86 platform

The output of prime-select is
Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
While prime-select query gives:
I also tried to force nvidia by running prime-select nvidia
but same result.
Please advise.
Thank you

Hi @gritelli
Welcome to the Stereolabs community.

After the command prime-select nvidia you must reboot the system.
Read more here:

sorry for being late on this, i followed the guideline you linked to me, but after running sudo prime-select nvidia it tells me : ‘Error: no integrated GPU detected.’
also let me append the nvidia-smi output.

@franzhd please verify the setting in the BIOS of the laptop.
You must be sure that the automatic GPU selection is disabled and the NVIDIA GPU is the default selection.

Hello, i have a desktop computer with a ryzen 5 3600 that has no integrated gpu. On my MSI board there is no such option unfortunately.

Can you run the ZED Diagnostic tool and send the report file it generates to

Ias i show you before, the zed diagnostic file outputs an empty json file, due to the error i’m facing

Can you try to update the NVIDIA driver to the most recent version?

Hello, sorry for being late on the topic, i did update the nvidia driver to 530 and with cuda 12.1, but i still have the problem. It seems like a problem with usb stuff. Infact it gave me problem also inside the docker.
This is my console output for ZED_Diagnostics, nvidia-smi and nvcc.

I just noticed that it’s the libusb that crashes. I was focusing to the wrong part of the error message.
Can you please post the output of the commands $ lsusb -d 2b03:?
Can you also please try to open the ZED Sensors Viewer tool and let me know if it starts and provides IMU data?

Opening the ZED_Sensors_Viewer do show nothing and crashes after few seconds, while the blue light on the camera blink.
Thanks again for your support

Please start the ZED Sensor Viewer from the console and post the command log if there’s something useful to report

this is the shell log

Hello @Myzhar, thanks for the support, going deeper on this and other problems that i found on my system, i finally found the problem. I had broken packages on my machine that were not updated due to a checkmark in “software and update” settings that prevented the system to upgrade the available packages to newer version. There was a confirmed problem with udev package, that was fixed last year, but my version was blocked before that fix. updating and upgrading after unchecking that option resolved the problem. That was untrackable before trying the ZED and installing ROS2 humble. Finally i can use the ZED camera on my desktop :partying_face: .
Thanks again for your fast answers, help and support!

1 Like