Error while opeing ZED_Depth_Viewer


I am installed latest ZED SDK on ubuntu 20.04. I got an error message when I ran ZED_Depth_Viewer. Any suggestion to solve this issue? I purged Nvidia related stuff and reinstalled ZED from the scratch. But I still get this error.

[ZED Depth Viewer] CUDA - OpenGL Interop Failed with Err Code 999
Stack trace (most recent call last):
#20 Object “[0xffffffffffffffff]”, at 0xffffffffffffffff, in
#19 Object “ZED_Depth_Viewer”, at 0x4262bd, in
#18 Object “/lib/x86_64-linux-gnu/”, at 0x7f24183c3082, in __libc_start_main
#17 Object “ZED_Depth_Viewer”, at 0x4256d4, in
#16 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418b6a115, in QCoreApplication::exec()
#15 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418b623aa, in QEventLoop::exec(QFlagsQEventLoop::ProcessEventsFlag)
#14 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418bbb434, in QEventDispatcherGlib::processEvents(QFlagsQEventLoop::ProcessEventsFlag)
#13 Object “/lib/x86_64-linux-gnu/”, at 0x7f2416c254a2, in g_main_context_iteration
#12 Object “/lib/x86_64-linux-gnu/”, at 0x7f2416c253ff, in
#11 Object “/lib/x86_64-linux-gnu/”, at 0x7f2416c2517c, in g_main_context_dispatch
#10 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418bbbe36, in
#9 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418b66487, in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*)
#8 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418b63809, in QCoreApplication::notifyInternal2(QObject*, QEvent*)
#7 Object “/lib/x86_64-linux-gnu/”, at 0x7f24195870ef, in QApplication::notify(QObject*, QEvent*)
#6 Object “/lib/x86_64-linux-gnu/”, at 0x7f241957da65, in QApplicationPrivate::notify_helper(QObject*, QEvent*)
#5 Object “/lib/x86_64-linux-gnu/”, at 0x7f24195c025c, in QWidget::event(QEvent*)
#4 Object “/lib/x86_64-linux-gnu/”, at 0x7f2418b8fc29, in QObject::event(QEvent*)
#3 Object “ZED_Depth_Viewer”, at 0x452a75, in
#2 Object “ZED_Depth_Viewer”, at 0x4b55c5, in
#1 Object “ZED_Depth_Viewer”, at 0x4725cd, in
#0 Object “/lib/x86_64-linux-gnu/”, at 0x7f242370ca39, in
Segmentation fault (Address not mapped to object [0x400000001])
Segmentation fault (core dumped)

Hi @jlee
You can find the solution in this thread: