Docker zed3.8-cuda11.7-ubuntu20.04+ros_wrapper

hello i am Using Docker zed3.8-cuda11.7-ubuntu20.04 ; i have build ros noetic on it and i tried building the zed_ros_wrapper package on the docker and i have been having the error in catkin_make

after passing catkin_make -DCUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda i still have

CMake Error at /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
CUDA_CUDART_LIBRARY) (Required is at least version “11”)
Call Stack (most recent call first):
/usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.16/Modules/FindCUDA.cmake:1104 (find_package_handle_standard_args)
/usr/local/zed/zed-config.cmake:72 (find_package)
zed-ros-wrapper/zed_nodelets/CMakeLists.txt:22 (find_package)
– Configuring incomplete, errors occurred!
See also “/zed_ws/build/CMakeFiles/CMakeOutput.log”.
See also “/zed_ws/build/CMakeFiles/CMakeError.log”.
Invoking “cmake” failed

i tried passing the values for missing but still have the error.
please help me build this image or please guide me if there exist such docker image

Hi @lilweary
Welcome to the Stereolabs community.

Why are you building ROS Noetic in an Ubuntu 20.04 Docker Image?
You can install the binaries using APT and follow the ROS guide since ROS Noetic is directly supported by Ubuntu 20.04.

Furthermore, to build the ZED ROS Wrapper you need a devel Docker image, not runtime:
3.8-devel-cuda11.7-ubuntu20.04 not 3.8-runtime-cuda11.7-ubuntu20.04 from Docker