DLL load failed

I am unable to import pyzed.sl. The error is ImportError: DLL load failed: The specified module could not be found, which has been previously reported. I am on windows 10 and tried on python 3.6 and 3.7 and get the same error in both versions.
windows 10
pyzed 3.5
cuda 11.0 and associated zed sdk 3.5.6(zed2envpy3.7) C:\Users\s1092127\Documents\Python Scripts>python get_python_api.py
→ Downloading to ‘C:\Users\s1092127\Documents\Python Scripts’
Detected platform:
win
Python 3.7
CUDA 11.0
ZED SDK 3.5 (requiring CUDA 11.0)
→ Checking if https://download.stereolabs.com/zedsdk/3.5/win/cu110/py37 exists and is available
→ Found ! Downloading python package into C:\Users\s1092127\Documents\Python Scripts\pyzed-3.5-cp37-cp37m-win_amd64.whl
→ Installing necessary dependencies
Requirement already satisfied: numpy in c:\users\s1092127\anaconda3\envs\zed2envpy3.7\lib\site-packages (1.21.2)
Processing c:\users\s1092127\documents\python scripts\pyzed-3.5-cp37-cp37m-win_amd64.whl
Collecting cython>=0.28
Downloading Cython-0.29.24-cp37-cp37m-win_amd64.whl (1.6 MB)
|████████████████████████████████| 1.6 MB 2.2 MB/s
Collecting numpy>=1.13
Downloading numpy-1.21.2-cp37-cp37m-win_amd64.whl (14.0 MB)
|████████████████████████████████| 14.0 MB 6.4 MB/s
Installing collected packages: numpy, cython, pyzed
Successfully installed cython-0.29.24 numpy-1.21.2 pyzed-3.5
Done
Installing OpenGL dependencies required to run the samples
→ Downloading PyOpenGL-3.1.5-cp37-cp37m-win_amd64.whl
Processing c:\users\s1092127\documents\python scripts\pyopengl-3.1.5-cp37-cp37m-win_amd64.whl
Installing collected packages: PyOpenGL
Attempting uninstall: PyOpenGL
Found existing installation: PyOpenGL 3.1.1a1
Uninstalling PyOpenGL-3.1.1a1:
Successfully uninstalled PyOpenGL-3.1.1a1
Successfully installed PyOpenGL-3.1.5
→ Downloading PyOpenGL_accelerate-3.1.5-cp37-cp37m-win_amd64.whl
Processing c:\users\s1092127\documents\python scripts\pyopengl_accelerate-3.1.5-cp37-cp37m-win_amd64.whl
Installing collected packages: PyOpenGL-accelerate
Successfully installed PyOpenGL-accelerate-3.1.5
To install it later or on a different environment run :
python -m pip install --ignore-installed C:\Users\s1092127\Documents\Python Scripts\pyzed-3.5-cp37-cp37m-win_amd64.whl

Is GPU a requirement for any form of data collection using the zed2?

Hi @narayaba,

I am sorry you are facing issues with the SDK.

Here are a few things you can check :

  • It seems that you installed the Python API inside a virtual environment. Can you make sure that it is well activated when launching the script that uses the API ?
  • If it is the case, can you try installing the API outside the virtual environment ?
  • You can also try to install the API from the sources here
  • If none of the above works, can you visit this github thread and see if the suggested workarounds help with your problem

In order to use the ZED SDK, you indeed need an NVIDIA GPU. You can find the full requirement list on this page.

Thanks for your reply. How do you collect both the stereo recordings (left and right video), depth map and the sensor data via a gui all at the same time?