Can't install

Hi there I’m just a beginner for ZED, I followed setup tutorial step by step in official website and when I install the python api, I can’t install the file “” from ZED SDK, so what’s worry…

This is surprising as the file exists and can be downloaded (I just check by directly accessing the link

Can you access it from a browser ? it should download the python whl file.
If you still have an error it may be due to either an internet connection issue or SSL problem (wrong date or time that cause invalid certificate) or our cache server have some issues.
Just in case the direct link is

1 Like

sorry to interrupt you,but i think i meet with the similar problem,the link i can see is “”,for the platform i use is
Detected platform:
Python 3.6

i can’t access the link ,i wonder if there is something wrong with my net.actually i can’t get link1 you write in the answer,but i can get link2 , so could you please just show me the direct link due the platform i use.
Thanks a lot

Hi @meihui,

Here is the direct link :
Can you try it out and see if it works better ?


Both the links you mentioned are not working currently. When I put it in the browser it returns a 404 not found error.

Is there an updated working link for SDK 3.6? I am having trouble getting the right link for the .whl file. My get_python_api script is giving me a link that does not work.

I am running on Windows 10, but also have a machine with Ubuntu 20 and the link generated through there also did not work.


this links is also not working. Get an 404 error.

Hello, there is an issue with your link. It’s actually [](
Did generate that ?

Ah ok. Yes this link is generated by the…

1 Like

I have made the following changes in Now it works.

  • change base_URL to
  • whl-file_url is still the old one (
  • change OS_Version (add _amd64)

1 Like


1 Like

Thanks @Dan! That worked for me (same issue).

Hi !
I’m glad you could find a workaround. Just a few tips if someone reads this later.

The base_URL did not change. redirects to, so that if we change our online space provider it does not impact you.

For example, redirects to

Thus you do not need to add _amd64 to your script.

However, you should always use the script that is fitting your SDK version. I think that is the issue here, you used an old version of the script.