Cannot find TENSORT when installing ZED SDK v3.8.2 for L4T35.1


I am facing the error Cannot find TENSORT when installing the ZED SDK v3.8.2 using the script Please find below some information about my config:

  1. I flashed a Jetson AGX Orin DevKit with JetPack SDK 5.0.2 / L4T 35.1 using the SDK Manager.
cat /etc/nv_tegra_release
# R35 (release), REVISION: 1.0, GCID: 31346300, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 25 18:41:45 UTC 2022
  1. TensorRT 8.4.1 seems legitimately installed
dpkg -l | grep TensorRT
ii  libnvinfer-bin                             8.4.1-1+cuda11.4                     arm64        TensorRT binaries
ii  libnvinfer-plugin8                         8.4.1-1+cuda11.4                     arm64        TensorRT plugin libraries
ii  libnvinfer8                                8.4.1-1+cuda11.4                     arm64        TensorRT runtime libraries
ii  libnvonnxparsers8                          8.4.1-1+cuda11.4                     arm64        TensorRT ONNX libraries
ii  libnvparsers8                              8.4.1-1+cuda11.4                     arm64        TensorRT parsers libraries
ii  nvidia-tensorrt                            5.0.2-b231                           arm64        NVIDIA TensorRT Meta Package
ii  tensorrt-libs                                       arm64        Meta package for TensorRT runtime libraries
  1. The Python bindings for TensorRT was missing for Python 3.8. So, I downloaded TensorRT GA build from NVIDIA Developer Zone, and I installed the pre-compiled wheel package for Python 3.8 bindings.
TensorRT wheel package install
pip3 install ~/Downloads/TensorRT-
python3 -c "import tensorrt as trt; print(trt.__version__)"

Still, the installation script fails to locate TensoRT. Would you please help me to find out why it fails ?

ā€“ Howard

ZED Diagnostic

Hi, and welcome to our forum,
Your TensorRT version seems right indeed. Did you tune the installation in anyway after the flash ? Did you use the whole SDK manager process, or did you run sudo apt install nvidia-jetpack ?

Can you try your tensorrt setup ? With the samples in /usr/src/tensorrt/samples/, and use /usr/src/tensorrt/bin/trtexec to execute a random model.
You can also download these samples from there : TensorRT/samples at main Ā· NVIDIA/TensorRT Ā· GitHub

If these do not work, Iā€™m afraid the quickest solution will be to reflash your Orin (or maybe just reinstall the jetpack with apt).


Hi, thanks a lot for replying,

First, I downloaded the TensorRT examples and then tried the TensorRT setup by running the python/yolov3_to_onnx example. It worked just fine.

At this point, I had no idea why TensorRT was not detected. So I forced reinstalling nvidia-jetpack using sudo apt --reinstall install nvidia-jetpack. Hopefully, it solved my issue.

Thank you! Best regards,
ā€“ Howard

1 Like