Cannot enable GNSS fusion


I am using the ZED2i with a Jetson Orin, and trying to get the gnss fusion working with the ROS2 Wrapper.

I have:
Ubuntu 20.04
Nvidia Jetson Orin

I installed everything just recently according to the instructions on:

I installed:
ROS2 Foxy
[ZED SDK for JetPack 5.1 (L4T 35.2)] 4.0 (Jetson Xavier, Orin AGX/NX 16GB, CUDA 11.4)

The ZED ROS2 node runs fine.

Then I tried to enable GNSS fusion by setting the ROS2 parameter ‘gnss_fusion.gnss_fusion_enabled’ to true. Here is what I get:

host:~/ros2_ws$ ros2 param set /zed2i/zed_node gnss_fusion.gnss_fusion_enabled True
Setting parameter failed: parameter ‘gnss_fusion.gnss_fusion_enabled’ cannot be set because it is read-only

Note that the default of this parameter is false:

host:~/ros2_ws$ ros2 param get /zed2i/zed_node gnss_fusion.gnss_fusion_enabled
Boolean value is: False

How can enable GNSS fusion if the parameter that enables it is read-only?


Hi @farbod
Welcome to the Stereolabs community.

The parameter is not dynamic, you cannot enable it when the node is running.
You must change the value in the common.yaml file or modify the launch file to overwrite it.

Hi Myzhar,

Thanks for the tip. It worked!


1 Like

It’s always my pleasure :+1: