Camera Zed2i not detected under Ubuntu 18.04 and 20.04

I am using a PC Omen desktop with GTX1080TI, which has 3 OS (Win10, Ubuntu18 and Ubuntu20).
Under Win10 I have no issues in viewing Zed2i with different SDK tools. Diagnostic and explorer all ok.

Under Ubuntu 18 and 20, however, the camera is not detected. I connected it to all possible USB ports of my PC, but the diagnostic tool says “camera not detected” when testing the camera. SDK, processor and graphic tests are ok.

If I run lsusb I get the following (but no names of the device after the ID)
Bus 001 Device 007: ID 2b03:f881
Bus 001 Device 005: ID 2b03:f880

if I run dmesg I get the following
624.767719] usb 1-5: new high-speed USB device number 11 using xhci_hcd
[ 624.915876] usb 1-5: New USB device found, idVendor=0424, idProduct=2512, bcdDevice= b.b3
[ 624.915882] usb 1-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 624.917815] hub 1-5:1.0: USB hub found
[ 624.917865] hub 1-5:1.0: 2 ports detected
[ 625.207499] usb 1-5.2: new full-speed USB device number 12 using xhci_hcd
[ 625.310538] usb 1-5.2: New USB device found, idVendor=2b03, idProduct=f881, bcdDevice= 3.09
[ 625.310544] usb 1-5.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 625.310548] usb 1-5.2: Product: ZED-2i HID INTERFACE
[ 625.310551] usb 1-5.2: Manufacturer: STEREOLABS
[ 625.310554] usb 1-5.2: SerialNumber: 36038824
[ 625.321702] hid-generic 0003:2B03:F881.0007: hiddev0,hidraw0: USB HID v1.11 Device [STEREOLABS ZED-2i HID INTERFACE] on usb-0000:00:14.0-5.2/input0
[ 625.543712] usb 1-5.1: new high-speed USB device number 13 using xhci_hcd
[ 625.645537] usb 1-5.1: New USB device found, idVendor=2b03, idProduct=f880, bcdDevice= 1.00
[ 625.645543] usb 1-5.1: New USB device strings: Mfr=1, Product=2, SerialNumber=4
[ 625.645546] usb 1-5.1: Product: ZED 2i
[ 625.645549] usb 1-5.1: Manufacturer: Technologies, Inc.
[ 625.645552] usb 1-5.1: SerialNumber: OV0001
[ 625.649416] uvcvideo: Found UVC 1.10 device ZED 2i (2b03:f880)
[ 625.653365] input: ZED 2i: ZED 2i as /devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.1/1-5.1:1.0/input/input22

Any advice?
Thank you

Hi @guyver30 he latest update of the Kernel of Ubuntu broke the connection between the UVC kernel driver and the ZED SDK because it changed the way how a parameter is handled.
We already solved the problem and the fix is available in the ZED SDK release v3.6.5:

Thank you very much. That worked!

1 Like

Does this also mean, that I cannot use the ‘zed-open-capture’ library to record raw images? In other words, I necessarily need the SDK and thus CUDA to use my ZED2i?

edit. Seems I am able to stream video in Ubuntu with the ‘zed_open_capture_video_example’

@luchs this post is out of topic in this thread