Body Tracking Example - Python - Runs but no tracking


Just got my camera and got it up and running.

I’m able to get the example Body Tracking code running but the code doesn’t actually detect it seems.

I’m running CUDA 11.7 and the correct SDK it seems.

The preview 2D window looks good but the tracking window is black and doesn’t detect.

Running diagnostics shows info on non optimized tracking in the AI models but everything else seems to pass.

I did the calibration a few times too to make sure that wasn’t the issue. Anything else I can check?

Perhaps this is a clue? I see a lot of colorful noise etc in the zedfu and it’s not mapping properly it seems? (Sorry for my newness)

Not sure I made sense on my initial post, but when running the code, the Zed 2D View shows a video stream. This is good. The Body Tracking window is completely black with nothing on it. Neither window shows any skeletal points etc… No tracking or bounding boxes etc… No output from terminal either.

Object tracking demos all seem to not really identify anything. This feels like maybe a calibration issue or something? I’ve tried calibrating multiple times as well now.


Our objects detection features use AI models and they cannot run without being optimized first. However, if these are not optimized, the optimization should be automatic.
What SDK version are you using ? Can you run ZED Diagnostics with -aio as argument ?


Thank you! I’m running the -aio now Should finish in about a half hour it seems? Will re run tests and let you know.

@alassagne - Running the -aio switch seems to have completed successfully.

SDK Version: ZED_SDK_Windows10_cuda11.7_v3.7.7

c:\Program Files (x86)\ZED SDK\tools>"ZED Diagnostic.exe" -aio

Optimizing all AI models
 Downloading objects_performance_2.2  100.0%[========================================] 19.7/19.7 MB              Done
 Optimizing objects_performance_2.2 |  100.0%[=============================>] Done ! in 3min 59s
 Downloading objects_medium_2.2  100.0%[========================================] 57.6/57.6 MB              Done
 Optimizing objects_medium_2.2 |  100.0%[=============================>] Done ! in 2min 37s
 Downloading objects_accurate_2.2  100.0%[========================================] 126.3/126.3 MB              Done
 Optimizing objects_accurate_2.2 |  100.0%[=============================>] Done ! in 2min 55s
 Downloading skeleton_performance_2.1  100.0%[========================================] 27.8/27.8 MB              Done
 Optimizing skeleton_performance_2.1 |  100.0%[=============================>] Done ! in 2min 45s
 Downloading skeleton_medium_2.0  100.0%[========================================] 27.8/27.8 MB              Done
 Optimizing skeleton_medium_2.0 |  100.0%[=============================>] Done ! in 2min 5s
 Downloading skeleton_accurate_2.0  100.0%[========================================] 95.3/95.3 MB              Done
 Optimizing skeleton_accurate_2.0 |  100.0%[=============================>] Done ! in 1min 7s
 Downloading person_head_performance_2.4  100.0%[========================================] 4.8/4.8 MB              Done
 Optimizing person_head_performance_2.4 |  100.0%[=============================>] Done ! in 2min 13s
 Downloading person_reid_1.4  100.0%[========================================] 8.4/8.4 MB              Done
 Optimizing person_reid_1.4 |  100.0%[=============================>] Done ! in 1min 1s
Optimizing: NEURAL DEPTH...
 Downloading neural_depth_1.3  100.0%[========================================] 17.6/17.6 MB              Done
 Optimizing neural_depth_1.3 |  100.0%[=============================>] Done ! in 4min 55s

But running the diagnostic again still shows all of those as “not optimized” and the body tracking example still provides zero tracking ability and all of the same symptoms as above.


This is very weird. First, your models should have been installed automatically, then the installation does not change anything. You probably have some parts of TensorRT installations somewhere. I assume you have the right nvidia driver, but can you send us the ZED Diagnostic file ?
The next step will be to remove CUDA and everything related to it, and then install the latest SDK. The SDK will install the CUDA it needs.


Not sure what’s up with the AI models. But my camera test keeps failing all of a sudden too. Saying certain resolutions not supported try another usb3 port. This is new and USB passes with adequate bandwidth. This camera fail on diagnostics just started. Tried all available usb3 ports.

It won’t let me upload my results so here is a link:

Your hardware seems allright, but your models are still reported as not optimized. I’ll still bet on a corrupted cuda / tensorrt installation. Can you proceed to a reinstallation ?
Changing USB port was indeed a good idea. What happens when you run our tool ZED Explorer ? This one does not need CUDA. It can help us find out if there is an hardware issue with the Camera.

Everything is uninstalled. Downloading latest SDK now.

Question … The USB Cable I’m using is the longer one and it has a female Micro USB port on it. Do I need to power inject this thing?

Ok / AI Models still a no go but got camera and usb to go green. Yay.

Running Explorer looks like it works just fine for showing video etc… Anything in particular I should look at in that app? Should I try to re build the ai models again manually?

Hi again,

I don’t know about a cable with a female micro usb. Was it provided by us ? It seems weird, the ZED2i that you have requires a USB-C cable. It’s pretty standard, but you should try with the one you got with the zed just to be sure.

The next step would be running ZED Depth Viewer. If this one runs, your nvidia setup is not so bad.
In Depth Viewer, you can then tune the settings to enable NEURAL depth. If this one works, any AI feature should work.

Also : do you have another camera to try on your computer, or another computer to try this camera on ?

Yes it’s the one that came from Zed - It has a screw in cable for the camera then about half way down is a little box with a mini USBC female on it. then it terminates as a USB male. Weird…

Anyway… It’s running Depth viewer but it looks kinda jacked up… Not sure how it should look but here’s a video of it in action:

No other windows machines / other than some crappy surface go tablets.

It’s not necessary wrong, it depends a lot of the parameters you use. Depth mode, minimum range, confidence threshold. Especially if the minimum range is too high. And can you try NEURAL ?