AttributeError: '' object has no attribute 'keypoint'

Hi, I got this error while trying to run the file in the custom detector folder:

AttributeError: ‘’ object has no attribute ‘keypoint’

The error is in this line of code:
keypoints = _objs.object_list[i].keypoint

Seems like the samples haven’t been updated to reflect the function updates of the new SDK version. I fixed a bunch of camera_config errors that also referred to the syntax of the old SDK version, but haven’t been able to figure this out yet.

Any help would be appreciated!


Are you using 4.0.2 and the latest samples ? We were late on the update indeed, but now it should work.
ObjectData no more has keypoint, we divided it into ObjectData and BodyData to separate object detection and body tracking.

Yes, I am using the latest versions. I believe the error is in the updateData method of in the ogl_viewer folder in custom detector.

It still tries to extract keypoints from an ObjectData object (line 535). I didn’t need that part anyway so I commented it out, and it works now.

You’re right, it still not up to date. Thank you for reporting it.

Antoine Lassagne
Senior Developer - ZED SDK
Stereolabs Support